You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
zope.interface/tox.ini

69 lines
1.5 KiB

# Generated from:
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[tox]
minversion = 3.18
envlist =
lint
py27,py27-pure
py35,py35-pure
py36,py36-pure
py37,py37-pure
py38,py38-pure
py39,py39-pure
py310,py310-pure
py311,py311-pure
pypy
pypy3
docs
coverage
[testenv]
usedevelop = true
pip_pre = py311: true
deps =
Sphinx
setenv =
pure: PURE_PYTHON=1
!pure-!pypy-!pypy3: PURE_PYTHON=0
ZOPE_INTERFACE_STRICT_IRO=1
commands =
coverage run -p -m unittest discover -s src {posargs}
!py27-!pypy: sphinx-build -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
extras =
test
docs
[testenv:coverage]
basepython = python3
allowlist_externals =
mkdir
deps =
coverage
setenv =
PURE_PYTHON=1
commands =
mkdir -p {toxinidir}/parts/htmlcov
coverage combine
coverage html -i
coverage report -i -m --fail-under=99
depends = py27,py27-pure,py35,py35-pure,py36,py36-pure,py37,py37-pure,py38,py38-pure,py39,py39-pure,py310,py310-pure,pypy,pypy3,docs
parallel_show_output = true
[testenv:lint]
basepython = python3
skip_install = true
commands =
check-manifest
check-python-versions
deps =
check-manifest
check-python-versions >= 0.19.1
wheel
[testenv:docs]
basepython = python3
skip_install = false
commands_pre =
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest