Browse Source

Drop support for Python 3.4 (#321)

* Drop support for Python 3.4

Python 3.4 is no longer supported. Even pyenv is failing to install it
for me, because apparently the currnet version of `ensurepip` bombs for
3.4. Pypiserver may still work on 3.4, but testing on it has becomes
more of a hassle than it's worth.

* Fix @mplanchard's email address

Just realized my email address in the authors' file has been wrong for
pretty much forever.

* Remove GL CI

GitLab CI is nice, but doesn't support forks, and so isn't going to be
viable for this project.
pull/323/head
Matthew Planchard 2 years ago committed by GitHub
parent
commit
b1bf1ed248
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
  1. 91
      .gitlab-ci.yml
  2. 1
      .travis.yml
  3. 2
      AUTHORS.rst
  4. 1
      CHANGES.rst
  5. 2
      README.rst
  6. 1
      setup.py
  7. 2
      tox.ini

91
.gitlab-ci.yml

@ -1,91 +0,0 @@
stages:
- test
default:
image: python:3
.base_test:
stage: test
coverage: '/^TOTAL.*\s+(\d+\%)$/'
except:
- standalone
before_script:
- apt-get update && apt-get install -y zip
- pip install tox
- ./bin/test_standalone.sh
test-docker:
image: docker:latest
services:
- name: docker:dind
alias: localhost
except:
- standalone
before_script:
- apk add --no-cache curl python3 python3-dev gcc libffi-dev musl-dev openssl-dev
- pip3 install twine
script:
- ./bin/test-docker.sh
validate-readme:
image: python:3
except:
- standalone
before_script:
- pip install sphinx
script:
- ./bin/check_readme.sh
test-2.7:
extends: .base_test
image: python:2.7
script:
- tox -e py27
test-3.4:
extends: .base_test
image: python:3.4
script:
- tox -e py34
test-3.5:
extends: .base_test
image: python:3.5
script:
- tox -e py35
test-3.6:
extends: .base_test
image: python:3.6
script:
- tox -e py36
test-3.7:
extends: .base_test
image: python:3.7
script:
- tox -e py37
test-3.8:
extends: .base_test
image: python:3.8
script:
- tox -e py38
test-pypy-2:
extends: .base_test
image: pypy:2
before_script:
- pypy -m pip install tox
script:
- tox -e pypy
test-pypy-3:
extends: .base_test
image: pypy:3
# TODO: figure out why this is failing in GL but not in Travis
allow_failure: true
before_script:
- pypy3 -m pip install tox
script:
- tox -e pypy3

1
.travis.yml

@ -4,7 +4,6 @@ services: docker
python:
- 2.7
- 3.4
- 3.5
- 3.6
- 3.7

2
AUTHORS.rst

@ -5,7 +5,7 @@ AUTHORS
- Ralf Schmitt <ralf@systemexit.de>,
- Kostis Anagnostopoulos <ankostis@gmail.com>
- Matthew Planchard <mplanchard@gmail.com>
- Matthew Planchard <msplanchard@gmail.com>
- run ``git log --format='%aN' | sort -u`` to see all contributors, or::
git log --format='%aN <%aE>' |

1
CHANGES.rst

@ -8,6 +8,7 @@ x.x.x (tbd)
- MAINT: Update bottle to [0.12.18](https://github.com/bottlepy/bottle/releases/tag/0.12.18)
for Python 3.8 compatibility
- MAINT: bump version of passlib from 1.7.1 to 1.7.2 in Docker requirements
- MAINT: drop official support for Python 3.4
1.3.2 (2020-01-11)
------------------

2
README.rst

@ -43,7 +43,7 @@ with ``scp``.
Quickstart: Installation and Usage
==================================
``pypiserver`` > 1.2.x works with Python 2.7 and 3.4+ or PyPy.
``pypiserver`` > 1.2.x works with Python 2.7 and 3.5+ or PyPy.
Older Python versions may still work, but they are not tested.
For legacy Python versions, use ``pypiserver-1.1.x`` series.

1
setup.py

@ -67,7 +67,6 @@ setup(
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",

2
tox.ini

@ -1,5 +1,5 @@
[tox]
envlist = py27,py34,py35,py36,py37,py38,pypy,pypy3
envlist = py27,py35,py36,py37,py38,pypy,pypy3
[testenv]
deps=-r{toxinidir}/requirements/dev.pip

Loading…
Cancel
Save