Browse Source

DOC: small update to install.rst page (#14115)

Move some content from the removed content on dependencies from the README (see GH13882)
pull/13849/head
Joris Van den Bossche 6 years ago committed by GitHub
parent
commit
10bf721324
  1. 2
      README.md
  2. 21
      doc/source/install.rst

2
README.md

@ -148,7 +148,7 @@ pip install pandas
- [pytz](http://pytz.sourceforge.net)
- Needed for time zone support with ``pandas.date_range``
See the [full installation instructions](http://pandas.pydata.org/pandas-docs/stable/install.html)
See the [full installation instructions](http://pandas.pydata.org/pandas-docs/stable/install.html#dependencies)
for recommended and optional dependencies.
## Installation from sources

21
doc/source/install.rst

@ -254,11 +254,14 @@ Optional Dependencies
- `SQLite <https://docs.python.org/3.5/library/sqlite3.html>`__: for SQLite, this is included in Python's standard library by default.
* `matplotlib <http://matplotlib.org/>`__: for plotting
* `openpyxl <http://packages.python.org/openpyxl/>`__, `xlrd/xlwt <http://www.python-excel.org/>`__: Needed for Excel I/O
* `XlsxWriter <https://pypi.python.org/pypi/XlsxWriter>`__: Alternative Excel writer
* For Excel I/O:
* `xlrd/xlwt <http://www.python-excel.org/>`__: Excel reading (xlrd) and writing (xlwt)
* `openpyxl <http://packages.python.org/openpyxl/>`__: openpyxl version 1.6.1
or higher (but lower than 2.0.0), or version 2.2 or higher, for writing .xlsx files (xlrd >= 0.9.0)
* `XlsxWriter <https://pypi.python.org/pypi/XlsxWriter>`__: Alternative Excel writer
* `Jinja2 <http://jinja.pocoo.org/>`__: Template engine for conditional HTML formatting.
* `boto <https://pypi.python.org/pypi/boto>`__: necessary for Amazon S3
access.
* `boto <https://pypi.python.org/pypi/boto>`__: necessary for Amazon S3 access.
* `blosc <https://pypi.python.org/pypi/blosc>`__: for msgpack compression using ``blosc``
* One of `PyQt4
<http://www.riverbankcomputing.com/software/pyqt/download>`__, `PySide
@ -266,7 +269,7 @@ Optional Dependencies
<http://www.pygtk.org/>`__, `xsel
<http://www.vergenet.net/~conrad/software/xsel/>`__, or `xclip
<https://github.com/astrand/xclip/>`__: necessary to use
:func:`~pandas.io.clipboard.read_clipboard`. Most package managers on Linux distributions will have ``xclip`` and/or ``xsel`` immediately available for installation.
:func:`~pandas.read_clipboard`. Most package managers on Linux distributions will have ``xclip`` and/or ``xsel`` immediately available for installation.
* Google's `python-gflags <<https://github.com/google/python-gflags/>`__ ,
`oauth2client <https://github.com/google/oauth2client>`__ ,
`httplib2 <http://pypi.python.org/pypi/httplib2>`__
@ -274,7 +277,7 @@ Optional Dependencies
: Needed for :mod:`~pandas.io.gbq`
* `Backports.lzma <https://pypi.python.org/pypi/backports.lzma/>`__: Only for Python 2, for writing to and/or reading from an xz compressed DataFrame in CSV; Python 3 support is built into the standard library.
* One of the following combinations of libraries is needed to use the
top-level :func:`~pandas.io.html.read_html` function:
top-level :func:`~pandas.read_html` function:
* `BeautifulSoup4`_ and `html5lib`_ (Any recent version of `html5lib`_ is
okay.)
@ -287,14 +290,14 @@ Optional Dependencies
* if you install `BeautifulSoup4`_ you must install either
`lxml`_ or `html5lib`_ or both.
:func:`~pandas.io.html.read_html` will **not** work with *only*
:func:`~pandas.read_html` will **not** work with *only*
`BeautifulSoup4`_ installed.
* You are highly encouraged to read :ref:`HTML reading gotchas
<html-gotchas>`. It explains issues surrounding the installation and
usage of the above three libraries
* You may need to install an older version of `BeautifulSoup4`_:
- Versions 4.2.1, 4.1.3 and 4.0.2 have been confirmed for 64 and
32-bit Ubuntu/Debian
- Versions 4.2.1, 4.1.3 and 4.0.2 have been confirmed for 64 and
32-bit Ubuntu/Debian
* Additionally, if you're using `Anaconda`_ you should definitely
read :ref:`the gotchas about HTML parsing libraries <html-gotchas>`

Loading…
Cancel
Save