Bump actions/setup-python from 3 to 4 (#625)

Bumps [actions/setup-python](https://github.com/actions/setup-python) from 3 to 4.
- [Release notes](https://github.com/actions/setup-python/releases)
- [Commits](https://github.com/actions/setup-python/compare/v3...v4)

---
updated-dependencies:
- dependency-name: actions/setup-python
  dependency-type: direct:production
  update-type: version-update:semver-major
...

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
pull/609/head
dependabot[bot] 4 months ago committed by GitHub
parent 8965a4a33e
commit 6d5d9e089d
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
  1. 6
      .github/workflows/ci.yml
  2. 14
      action.yml

@ -13,7 +13,7 @@ jobs:
steps:
- uses: actions/checkout@v3
- name: Set up Python ${{ matrix.python-version }}
uses: actions/setup-python@v3
uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- name: Set up Miniconda
@ -31,7 +31,7 @@ jobs:
steps:
- uses: actions/checkout@v3
- name: Set up Python 3.9
uses: actions/setup-python@v3
uses: actions/setup-python@v4
with:
python-version: 3.9
- name: Install Nox-under-test
@ -44,7 +44,7 @@ jobs:
steps:
- uses: actions/checkout@v3
- name: Set up Python 3.9
uses: actions/setup-python@v3
uses: actions/setup-python@v4
with:
python-version: 3.9
- name: Install Nox-under-test

@ -7,26 +7,26 @@ branding:
runs:
using: composite
steps:
- uses: actions/setup-python@v3
- uses: actions/setup-python@v4
with:
python-version: "pypy-3.7"
- uses: actions/setup-python@v3
- uses: actions/setup-python@v4
with:
python-version: "pypy-3.8"
- uses: actions/setup-python@v3
- uses: actions/setup-python@v4
with:
python-version: "pypy-3.9"
- uses: actions/setup-python@v3
- uses: actions/setup-python@v4
with:
python-version: "3.7"
- uses: actions/setup-python@v3
- uses: actions/setup-python@v4
with:
python-version: "3.8"
- uses: actions/setup-python@v3
- uses: actions/setup-python@v4
with:
python-version: "3.9"
- uses: actions/setup-python@v3
- uses: actions/setup-python@v4
with:
python-version: "3.10"

Loading…
Cancel
Save