sanity_check: enforce minimum php version (5.4)

remotes/origin/jsonfeed-test-branch
Andrew Dolgov 7 years ago
parent b8619f8db0
commit bfd902bbcc
  1. 4
      include/sanity_check.php
  2. 4
      install/index.php

@ -43,8 +43,8 @@
array_push($errors, "Please don't run this script as root.");
}
if (version_compare(PHP_VERSION, '5.3.0', '<')) {
array_push($errors, "PHP version 5.3.0 or newer required.");
if (version_compare(PHP_VERSION, '5.4.0', '<')) {
array_push($errors, "PHP version 5.4.0 or newer required.");
}
if (CONFIG_VERSION != EXPECTED_CONFIG_VERSION) {

@ -39,8 +39,8 @@
function sanity_check($db_type) {
$errors = array();
if (version_compare(PHP_VERSION, '5.3.0', '<')) {
array_push($errors, "PHP version 5.3.0 or newer required.");
if (version_compare(PHP_VERSION, '5.4.0', '<')) {
array_push($errors, "PHP version 5.4.0 or newer required.");
}
if (!function_exists("curl_init") && !ini_get("allow_url_fopen")) {

Loading…
Cancel
Save