Browse Source

meson: fix typoed copy-paste error that override other dependencies to blkid

pull/1657/head
Eli Schwartz 3 months ago
parent
commit
eefff5aac7
No known key found for this signature in database
GPG Key ID: CEB167EFB5722BD6
  1. 4
      libmount/meson.build
  2. 4
      libsmartcols/meson.build
  3. 4
      libuuid/meson.build

4
libmount/meson.build

@ -87,7 +87,7 @@ lib_mount = library(
get_option('cryptsetup-dlopen').enabled() ? lib_dl : lib_cryptsetup,
realtime_libs],
install : build_libmount)
mount_dep = declare_dependency(link_with: lib_blkid, include_directories: '.')
mount_dep = declare_dependency(link_with: lib_mount, include_directories: '.')
if build_libmount
pkgconfig.generate(lib_mount,
@ -95,7 +95,7 @@ if build_libmount
subdirs : 'libmount',
version : pc_version)
if meson.version().version_compare('>=0.54.0')
meson.override_dependency('mount', blkid_dep)
meson.override_dependency('mount', mount_dep)
endif
endif

4
libsmartcols/meson.build

@ -42,7 +42,7 @@ lib_smartcols = both_libraries(
link_with : lib_common,
dependencies : build_libsmartcols ? [] : disabler(),
install : build_libsmartcols)
smartcols_dep = declare_dependency(link_with: lib_blkid, include_directories: '.')
smartcols_dep = declare_dependency(link_with: lib_smartcols, include_directories: '.')
lib_smartcols_static = lib_smartcols.get_static_lib()
@ -52,6 +52,6 @@ if build_libsmartcols
subdirs : 'libsmartcols',
version : pc_version)
if meson.version().version_compare('>=0.54.0')
meson.override_dependency('smartcols', blkid_dep)
meson.override_dependency('smartcols', smartcols_dep)
endif
endif

4
libuuid/meson.build

@ -37,7 +37,7 @@ lib_uuid = both_libraries(
dependencies : [socket_libs,
build_libuuid ? [] : disabler()],
install : build_libuuid)
uuid_dep = declare_dependency(link_with: lib_blkid, include_directories: dir_libuuid)
uuid_dep = declare_dependency(link_with: lib_uuid, include_directories: dir_libuuid)
if build_libuuid
pkgconfig.generate(lib_uuid,
@ -46,6 +46,6 @@ if build_libuuid
version : pc_version)
install_headers('src/uuid.h', subdir : 'uuid')
if meson.version().version_compare('>=0.54.0')
meson.override_dependency('uuid', blkid_dep)
meson.override_dependency('uuid', uuid_dep)
endif
endif

Loading…
Cancel
Save