Browse Source

ci: update Cirrus-CI image to FreeBSD 12.3

The FreeBSD CI build (on Cirrus-CI) has been failing in
't9001-send-email.sh' for quite some time, with an error from the
runtime linker relating to the Perl installation:

    $ GIT_SEND_EMAIL_NOTTY=1 git send-email \
    '--from=Example <from@example.com>' '--to=nobody@example.com' \
    '--smtp-server=/tmp/cirrus-ci-build/t/trash directory.t9001-send-email/fake.sendmail' \
    --compose '--subject=foo' 0001-Second.patch
    ld-elf.so.1: /usr/local/lib/perl5/5.32/mach/CORE/libperl.so.5.32: Undefined symbol "strerror_l@FBSD_1.6"

This first instance is in t9001.6 but it fails similarly in several tests
in this file.

The FreeBSD image we use is FreeBSD 12.2, which is unsupported since
March 31st, 2022 [1]. Switching to a supported version, 12.3,
makes this error disappear [2].

Change the image we use to FreeBSD 12.3.

[1] https://www.freebsd.org/security/unsupported/
[2] https://lore.kernel.org/git/9cc31276-ab78-fa8a-9fb4-b19266911211@gmail.com/

Reviewed-by: Carlo Marcelo Arenas Belón <carenas@gmail.com>
Signed-off-by: Philippe Blain <levraiphilippeblain@gmail.com>
Signed-off-by: Junio C Hamano <gitster@pobox.com>
pull/1274/head
Philippe Blain 3 months ago committed by Junio C Hamano
parent
commit
c58bebd4c6
  1. 2
      .cirrus.yml

2
.cirrus.yml

@ -9,7 +9,7 @@ freebsd_12_task:
DEFAULT_TEST_TARGET: prove
DEVELOPER: 1
freebsd_instance:
image_family: freebsd-12-2
image_family: freebsd-12-3
memory: 2G
install_script:
pkg install -y gettext gmake perl5

Loading…
Cancel
Save