Browse Source

INSTALL: mention that we need libcurl 7.19.4 or newer to build

Without NO_CURL=Y we require at least version "7.19.4" of libcurl, see
644de29e22 (http: drop support for curl < 7.19.4, 2021-07-30). Let's
document this in the "INSTALL" document.

Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com>
Signed-off-by: Junio C Hamano <gitster@pobox.com>
pull/1095/head
Ævar Arnfjörð Bjarmason 11 months ago committed by Junio C Hamano
parent
commit
59a399ed36
  1. 4
      INSTALL

4
INSTALL

@ -144,6 +144,10 @@ Issues of note:
not need that functionality, use NO_CURL to build without
it.
Git requires version "7.19.4" or later of "libcurl" to build
without NO_CURL. This version requirement may be bumped in
the future.
- "expat" library; git-http-push uses it for remote lock
management over DAV. Similar to "curl" above, this is optional
(with NO_EXPAT).

Loading…
Cancel
Save